aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-05 00:25:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 00:20:39 -0400
commit7b04616664d2858dbbf7277cdcd3ac3b4a9f1ad9 (patch)
tree1d92644c3126f1a2ea31049a6ac5b18835c1482d /gnu/packages/freedesktop.scm
parent0884238e1518f68e7d35b78dc2815fb35a3e641e (diff)
downloadguix-7b04616664d2858dbbf7277cdcd3ac3b4a9f1ad9.tar
guix-7b04616664d2858dbbf7277cdcd3ac3b4a9f1ad9.tar.gz
gnu: colord-gtk: Update to 0.3.0.
* gnu/packages/freedesktop.scm (colord-gtk): Update to 0.3.0. [build-system]: Use meson-build-system. [configure-flags] New argument. [native-inputs]: Replace intltool with gettext-minimal. [inputs]: Add pango-next. [propagated-inputs]: Replace gtk+ with gtk. [description]: Substitute GTK+ for GTK.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm28
1 files changed, 19 insertions, 9 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3548db7a6b..c7339eb00e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1770,27 +1770,37 @@ share connections to real-time communication services without conflicting.")
(define-public colord-gtk
(package
(name "colord-gtk")
- (version "0.1.26")
+ (version "0.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.freedesktop.org/software/colord"
"/releases/" name "-" version ".tar.xz"))
(sha256
(base32
- "0i9y3bb5apj6a0f8cx36l6mjzs7xc0k7nf0magmf58vy2mzhpl18"))))
- (build-system gnu-build-system)
- (arguments '(#:tests? #f)) ; require the colord system service
+ "1l61ydb0zv2ffilwpapgz5mm3bznr28zl16xqbxnz6kdsrb6cimr"))))
+ (build-system meson-build-system)
+ (arguments '(#:tests? #f ;require the colord system service
+ ;; Building documentation fails with: "Cannot build man pages
+ ;; without docbook-xsl-ns".
+ #:configure-flags (list "-Ddocs=false" "-Dman=false")))
(native-inputs
- (list gobject-introspection intltool pkg-config vala))
+ (list gettext-minimal
+ gobject-introspection
+ pkg-config
+ vala))
+ (inputs
+ ;; TODO: remove pango-next after it's the default.
+ (list gtk+
+ pango-next))
(propagated-inputs
;; colord-gtk.pc refers to all these.
- (list colord gtk+))
+ (list colord gtk))
(synopsis "GTK integration for libcolord")
(home-page "https://www.freedesktop.org/software/colord/")
(description
- "This is a GTK+ convenience library for interacting with colord. It is
-useful for both applications which need colour management and applications that
-wish to perform colour calibration.")
+ "This is a GTK convenience library for interacting with colord. It is
+useful for both applications which need colour management and applications
+that wish to perform colour calibration.")
(license license:lgpl2.1+)))
(define-public libfprint