aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-04-05 22:51:53 -0500
committerEric Bavier <bavier@member.fsf.org>2016-04-15 00:35:36 -0500
commit5ab869f962e767110530e79b50d08421ff7411ab (patch)
tree3b0aa0247998ce6097358f83ce1ef6e7a29f4fef /gnu/packages/fontutils.scm
parentf85cafde81df6f8cafd6148655c0a4ac089b3fae (diff)
downloadguix-5ab869f962e767110530e79b50d08421ff7411ab.tar
guix-5ab869f962e767110530e79b50d08421ff7411ab.tar.gz
gnu: fontforge: Use modify-phases.
* gnu/packages/fontutils.scm (fontforge)[arguments]: Use modify-phases.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm64
1 files changed, 31 insertions, 33 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index f37f343d52..e438aaf422 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -541,39 +541,37 @@ definitions.")
(arguments
'(#:tests? #f
#:phases
- (alist-cons-before
- 'configure 'patch-configure
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libxml2 (assoc-ref inputs "libxml2"))
- (cairo (assoc-ref inputs "cairo"))
- (pango (assoc-ref inputs "pango")))
- (substitute* "configure"
- ;; configure looks for a directory to be present to determine
- ;; whether libxml2 is available, rather than checking for the
- ;; library or headers. Point it to the correct directory.
- (("/usr/include/libxml2")
- (string-append libxml2 "/include/libxml2"))
- ;; Similary, the search directories for cairo and pango are
- ;; hard-coded.
- (("gww_prefix in.*") (string-append "gww_prefix in "
- cairo " " pango "\n")))))
- (alist-cons-after
- 'install 'set-library-path
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (potrace (string-append (assoc-ref inputs "potrace") "/bin")))
- (wrap-program (string-append out "/bin/fontforge")
- ;; Fontforge dynamically opens libraries.
- `("LD_LIBRARY_PATH" ":" prefix
- ,(map (lambda (input)
- (string-append (assoc-ref inputs input)
- "/lib"))
- '("libtiff" "libjpeg" "libpng" "giflib"
- "libxml2" "zlib" "libspiro" "freetype"
- "pango" "cairo" "fontconfig")))
- ;; Checks for potrace program at runtime
- `("PATH" ":" prefix (,potrace)))))
- %standard-phases))))
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libxml2 (assoc-ref inputs "libxml2"))
+ (cairo (assoc-ref inputs "cairo"))
+ (pango (assoc-ref inputs "pango")))
+ (substitute* "configure"
+ ;; configure looks for a directory to be present to determine
+ ;; whether libxml2 is available, rather than checking for the
+ ;; library or headers. Point it to the correct directory.
+ (("/usr/include/libxml2")
+ (string-append libxml2 "/include/libxml2"))
+ ;; Similary, the search directories for cairo and pango are
+ ;; hard-coded.
+ (("gww_prefix in.*") (string-append "gww_prefix in "
+ cairo " " pango "\n"))))))
+ (add-after 'install 'set-library-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (potrace (string-append (assoc-ref inputs "potrace") "/bin")))
+ (wrap-program (string-append out "/bin/fontforge")
+ ;; Fontforge dynamically opens libraries.
+ `("LD_LIBRARY_PATH" ":" prefix
+ ,(map (lambda (input)
+ (string-append (assoc-ref inputs input)
+ "/lib"))
+ '("libtiff" "libjpeg" "libpng" "giflib"
+ "libxml2" "zlib" "libspiro" "freetype"
+ "pango" "cairo" "fontconfig")))
+ ;; Checks for potrace program at runtime
+ `("PATH" ":" prefix (,potrace)))))))))
(synopsis "Outline font editor")
(description
"FontForge allows you to create and modify postscript, truetype and