aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2017-11-28 14:52:58 -0500
committerLeo Famulari <leo@famulari.name>2017-11-28 14:52:58 -0500
commit3715aff59ba232a7c9beae3978891530b8777f5d (patch)
tree0e57282f056c95acfd0ac5b706a1e1824f80dd9d /gnu/packages/fontutils.scm
parent76040f71f116b4f788d6748a523eaa4ea18d1cf0 (diff)
downloadguix-3715aff59ba232a7c9beae3978891530b8777f5d.tar
guix-3715aff59ba232a7c9beae3978891530b8777f5d.tar.gz
gnu: Add python2-defcon.
* gnu/packages/fontutils.scm (python2-defcon): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 1425045823..de6293aacd 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -585,3 +585,36 @@ generate bitmaps.")
"UfoLib reads and writes Unified Font Object (UFO)
files. UFO is a file format that stores fonts source files.")
(license license:bsd-3)))
+
+(define-public python2-defcon
+ (package
+ (name "python2-defcon")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "defcon" version ".zip"))
+ (sha256
+ (base32
+ "1f41w54fdjy9izxcwzqa142kd56whqsg9nq5k4508jb6iip84h89"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("python2-pytest-3.0" ,python2-pytest-3.0)
+ ("python2-pytest-runner" ,python2-pytest-runner)))
+ (propagated-inputs
+ `(("python2-fonttools" ,python2-fonttools)
+ ("python2-ufolib" ,python2-ufolib)))
+ (home-page "https://pypi.python.org/pypi/defcon")
+ (synopsis "Flexible objects for representing @acronym{UFO, unified font object} data")
+ (description
+ "Defcon is a set of @acronym{UFO, unified font object} based objects
+optimized for use in font editing applications. The objects are built to
+be lightweight, fast and flexible. The objects are very bare-bones and
+they are not meant to be end-all, be-all objects. Rather, they are meant
+to provide base functionality so that you can focus on your application’s
+behavior, not object observing or maintaining cached data. Defcon
+implements UFO3 as described by the UFO font format.")
+ (license license:expat)))