aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-01 10:27:46 +0000
committerArun Isaac <arunisaac@systemreboot.net>2017-08-06 10:49:52 +0530
commitabd8825f90472f7dcd2355c265de58a9c166beba (patch)
tree872f345b0a5a5e43c707696e8210e2062162fe1e /gnu/packages/fonts.scm
parent799097e445e67227313cbb4809a67cfc76081cf7 (diff)
downloadguix-abd8825f90472f7dcd2355c265de58a9c166beba.tar
guix-abd8825f90472f7dcd2355c265de58a9c166beba.tar.gz
gnu: Add font-open-dyslexic.
* gnu/packages/fonts.scm (font-open-dyslexic): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 51073eff9f..e421b2c6ab 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017 ng0 <ng0@no-reply.pragmatique.xyz>
+;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2016 Jookia <166291@gmail.com>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
@@ -1073,3 +1073,33 @@ resolutions.")
(synopsis "Fonts for MathJax")
(description "This package contains the fonts required for MathJax.")
(license license:asl2.0)))
+
+(define-public font-open-dyslexic
+ (package
+ (name "font-open-dyslexic")
+ (version "20160623")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/antijingoist/open-dyslexic/"
+ "archive/" version "-Stable.tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0al0j9kb32kfavcpq1kigsd36yzvf5yhzqhds0jkh7ngbxyxwkx4"))))
+ (build-system font-build-system)
+ (home-page "https://opendyslexic.org")
+ (synopsis "Font for dyslexics and high readability")
+ (description "OpenDyslexic is a font designed to help readability for some
+of the symptoms of dyslexia. Letters have heavy weighted bottoms to provide
+an indication of orientation to make it more difficult to confuse with other
+similar letters. Consistently weighted bottoms can also help reinforce the
+line of text. The unique shapes of each letter can help prevent flipping and
+swapping. The italic style for OpenDyslexic has been crafted to be used for
+emphasis while still being readable.")
+ (license
+ (license:fsdg-compatible
+ "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
+ "The Font Software may be sold as part of a larger software package but
+no copy of one or more of the Font Software typefaces may be sold by
+itself."))))