aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2017-08-05 17:21:23 +0000
committerLeo Famulari <leo@famulari.name>2017-11-28 14:22:28 -0500
commit4eb4742060b378071158bdd8794370a12ab04701 (patch)
tree7fe715c589bbccf0300c0710f3da93fe21ba4830 /gnu/packages/fonts.scm
parent27a10775805df96a5c6a77e8e03cbc172c50f5c7 (diff)
downloadguix-4eb4742060b378071158bdd8794370a12ab04701.tar
guix-4eb4742060b378071158bdd8794370a12ab04701.tar.gz
gnu: Add font-lato.
* gnu/packages/fonts.scm (font-lato): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index dbb3418e15..092b70e587 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -170,6 +170,45 @@ itself."))))
sans-serif designed for on-screen reading. It is used by GNOME@tie{}3.")
(license license:silofl1.1)))
+(define-public font-lato
+ (package
+ (name "font-lato")
+ (version "2.010")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.latofonts.com/download/Lato2OFL.zip"))
+ (sha256
+ (base32
+ "1f5540g0ja1nx3ddd3ywn77xc81ssrxpq8n3gyb9sabyq2b4xda2"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils)
+ (srfi srfi-26))
+
+ (let ((PATH (string-append (assoc-ref %build-inputs
+ "unzip")
+ "/bin"))
+ (font-dir (string-append %output
+ "/share/fonts/truetype")))
+ (setenv "PATH" PATH)
+ (system* "unzip" (assoc-ref %build-inputs "source"))
+
+ (mkdir-p font-dir)
+ (for-each (lambda (ttf)
+ (install-file ttf font-dir))
+ (find-files "." "\\.ttf$"))))))
+
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "http://www.latofonts.com/lato-free-fonts/")
+ (synopsis "Lato sans-serif typeface")
+ (description
+ "Lato is a sanserif typeface family. It covers over 3000 glyphs per style.
+The Lato 2.010 family supports more than 100 Latin-based languages, over
+50 Cyrillic-based languages as well as Greek and IPA phonetics.")
+ (license license:silofl1.1)))
+
(define-public font-gnu-freefont-ttf
(package
(name "font-gnu-freefont-ttf")