aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorCharlie Ritter <chewzerita@posteo.net>2018-03-06 10:59:47 -0500
committerLudovic Courtès <ludo@gnu.org>2018-03-07 11:22:42 +0100
commit270750d440b4b2c5f88694b5abc2c2b48046d173 (patch)
treef51af9955ea27dfe8274d3cf630d312698067f31 /gnu/packages/fonts.scm
parentabfbdafd0ee331770f783a75cff29aada9fbf4ae (diff)
downloadguix-270750d440b4b2c5f88694b5abc2c2b48046d173.tar
guix-270750d440b4b2c5f88694b5abc2c2b48046d173.tar.gz
gnu: Add IBM Plex font.
* gnu/packages/fonts.scm (font-ibm-plex): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 8af4f8dc83..aa9e466ebb 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
+;;; Copyright © 2018 Charlie Ritter <chewzerita@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,27 @@
#:use-module (gnu packages python)
#:use-module (gnu packages xorg))
+(define-public font-ibm-plex
+ (package
+ (name "font-ibm-plex")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/IBM/plex/releases/download/"
+ "v" version "/OpenType.zip"))
+ (sha256
+ (base32
+ "0nzxw9z6waixslam248yr26ci3fbk83c7jf6m90hncnaj6zxx795"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/IBM/plex")
+ (synopsis "IBM Plex typeface")
+ (description "This package provides the Plex font family. It comes in a
+Sans, Serif, Mono and Sans Condensed, all with roman and true italics. The
+fonts have been designed to work well in user interface (UI) environments as
+well as other mediums.")
+ (license license:silofl1.1)))
+
(define-public font-inconsolata
(package
(name "font-inconsolata")