aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2017-11-28 14:16:17 -0500
committerLeo Famulari <leo@famulari.name>2017-11-28 14:18:25 -0500
commit27a10775805df96a5c6a77e8e03cbc172c50f5c7 (patch)
tree649a1273fd3106b1749592f985c94c0efacbae76 /gnu/packages/fonts.scm
parent4440e40c6a950a3ccd5696c0227705b4688a56a1 (diff)
downloadguix-27a10775805df96a5c6a77e8e03cbc172c50f5c7.tar
guix-27a10775805df96a5c6a77e8e03cbc172c50f5c7.tar.gz
gnu: Add font-dosis.
* gnu/packages/fonts.scm (font-dosis): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 4acebeb405..dbb3418e15 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1070,3 +1070,52 @@ emphasis while still being readable.")
"The Font Software may be sold as part of a larger software package but
no copy of one or more of the Font Software typefaces may be sold by
itself."))))
+
+(define-public font-dosis
+ (package
+ (name "font-dosis")
+ (version "1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.impallari.com/media/releases/dosis-"
+ "v" version ".zip"))
+ (sha256
+ (base32
+ "1qhci68f68mf87jd69vjf9qjq3wydgw1q7ivn3amjb65ls1s0c4s"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils)
+ (srfi srfi-26))
+
+ (let ((PATH (string-append (assoc-ref %build-inputs
+ "unzip")
+ "/bin"))
+ (ttf-dir (string-append %output
+ "/share/fonts/truetype"))
+ (otf-dir (string-append %output
+ "/share/fonts/opentype")))
+ (setenv "PATH" PATH)
+ (system* "unzip" (assoc-ref %build-inputs "source"))
+
+ (mkdir-p ttf-dir)
+ (mkdir-p otf-dir)
+ (for-each (lambda (ttf)
+ (install-file ttf ttf-dir))
+ (find-files "." "\\.ttf$"))
+ (for-each (lambda (otf)
+ (install-file otf otf-dir))
+ (find-files "." "\\.otf$"))))))
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "http://www.impallari.com/dosis")
+ (synopsis "Very simple, rounded, sans serif family")
+ (description
+ "Dosis is a very simple, rounded, sans serif family.
+The lighter weights are minimalist. The bolder weights have more personality.
+The medium weight is nice and balanced. The overall result is a family
+that's clean and modern, and can express a wide range of voices & feelings.
+It comes in 7 incremental weights:
+ExtraLight, Light, Book, Medium, Semibold, Bold & ExtraBold")
+ (license license:silofl1.1)))