aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-09-17 21:07:22 +0200
committerAndreas Enge <andreas@enge.fr>2015-09-22 20:07:49 +0200
commit20c6b9dae3838894582ecefc9005c75316ad2f70 (patch)
tree9387ccdd0261ac2fbab0d64eaa2032afc775e830 /gnu/packages/finance.scm
parent61fe5a57a430c2593959b0aa95cc6ceebb3aeb8d (diff)
downloadguix-20c6b9dae3838894582ecefc9005c75316ad2f70.tar
guix-20c6b9dae3838894582ecefc9005c75316ad2f70.tar.gz
gnu: Add bitcoin-core.
* gnu/packages/finance.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Register it.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm82
1 files changed, 82 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
new file mode 100644
index 0000000000..264cfbf7f3
--- /dev/null
+++ b/gnu/packages/finance.scm
@@ -0,0 +1,82 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages finance)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build utils)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages protobuf)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages upnp))
+
+(define-public bitcoin-core
+ (package
+ (name "bitcoin-core")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://bitcoin.org/bin/bitcoin-core-"
+ version "/bitcoin-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "17yh6lq13xzzi5v2i48qaxiqm40x3hrj4gwyamkib9yzmmb1gfji"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper) ; for the tests
+ ("util-linux" ,util-linux))) ; provides the hexdump command for tests
+ (inputs
+ `(("bdb" ,bdb)
+ ("boost" ,boost)
+ ("miniupnpc" ,miniupnpc)
+ ("openssl" ,openssl)
+ ("protobuf" ,protobuf)
+ ("qt" ,qt)))
+ (arguments
+ `(#:configure-flags
+ (list
+ ;; We use a bdb version newer than 4.8.
+ "--with-incompatible-bdb"
+ ;; Boost is not found unless specified manually.
+ (string-append "--with-boost="
+ (assoc-ref %build-inputs "boost")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" (getenv "TMPDIR"))))))) ; Tests write to $HOME.
+ (home-page "https://bitcoin.org/en/")
+ (synopsis "Bitcoin peer-to-peer client")
+ (description
+ "Bitcoin is a digital currency that enables instant payments to anyone
+anywhere in the world. It uses peer-to-peer technology to operate without
+central authority: managing transactions and issuing money are carried out
+collectively by the network. Bitcoin Core is the reference implementation
+of the bitcoin protocol. This package provides the Bitcoin Core command
+line client and a client based on Qt.")
+ (license license:expat)))