aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-12-26 01:04:40 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-26 01:06:56 +0100
commit00d3f022b386713ab5d14a2ddfdf7f0fb866f366 (patch)
treeea8451d16e44353d53938bba25980d999ed7762c /gnu/packages/finance.scm
parentd0d5f7268805ea1a15ac8a74ce566731ff3209aa (diff)
downloadguix-00d3f022b386713ab5d14a2ddfdf7f0fb866f366.tar
guix-00d3f022b386713ab5d14a2ddfdf7f0fb866f366.tar.gz
gnu: Add python-trezor-agent.
* gnu/packages/finance.scm (python-trezor-agent, python2-trezor-agent): New variables.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 788f7c0d7c..ad36502810 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -492,3 +492,44 @@ Monero command line client and daemon.")
"Monero is a secure, private, untraceable currency. This package provides the
Monero GUI client.")
(license license:bsd-3)))
+
+(define-public python-trezor-agent
+ (package
+ (name "python-trezor-agent")
+ (version "0.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/romanz/trezor-agent/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0h8jb147vpjk7mqbl4za0xdh7lblhx07n9dfk80kn2plwnvrry1x"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
+ (invoke "py.test"))))))
+ (propagated-inputs
+ `(("python-ecdsa" ,python-ecdsa)
+ ("python-ed25519" ,python-ed25519)
+ ("python-semver" ,python-semver)
+ ("python-unidecode" ,python-unidecode)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/romanz/trezor-agent")
+ (synopsis "TREZOR SSH and GPG host support")
+ (description
+ "@code{libagent} is a library that allows using TREZOR, Keepkey and
+Ledger Nano as a hardware SSH/GPG agent.")
+ (license license:lgpl3)))
+
+(define-public python2-trezor-agent
+ (package-with-python2 python-trezor-agent))