aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2018-07-13 22:39:16 +0000
committerLudovic Courtès <ludo@gnu.org>2018-07-16 15:34:31 +0200
commita0bb021785e56a6cd20f7e0d69470665939fbd8b (patch)
tree300f1954e40f98aa16f6f6098b5fbde4affd397b /gnu/packages/finance.scm
parent66b9c643d5146f193182cd9ec5cf414aa6874b8c (diff)
downloadguix-a0bb021785e56a6cd20f7e0d69470665939fbd8b.tar
guix-a0bb021785e56a6cd20f7e0d69470665939fbd8b.tar.gz
gnu: Add electron-cash.
* gnu/packages/finance.scm (electron-cash): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 1d3e6a7a6a..29bf3040ed 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -329,6 +329,37 @@ generation from a seed. Your secret keys are encrypted and are never sent to
other machines/servers. Electrum does not download the Bitcoin blockchain.")
(license license:expat)))
+(define-public electron-cash
+ (package
+ (inherit electrum)
+ (name "electron-cash")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://electroncash.org/downloads/"
+ version
+ "/win-linux/ElectronCash-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1x487hyacdm1qhik1mhfimr4jwcwz7sgsbkh11awrb6j19sxdxym"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete the bundled dependencies.
+ (delete-file-recursively "packages")
+ #t))))
+ (home-page "https://electroncash.org/")
+ (synopsis "Bitcoin Cash wallet")
+ (description
+ "Electroncash is a lightweight Bitcoin Cash client, based on a client-server
+protocol. It supports Simple Payment Verification (SPV) and deterministic key
+generation from a seed. Your secret keys are encrypted and are never sent to
+other machines/servers. Electroncash does not download the Bitcoin Cash blockchain.")
+ (license license:expat)))
+
(define-public monero
;; This package bundles easylogging++ and lmdb.
;; The bundled easylogging++ is modified, and the changes will not be upstreamed.