aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-16 23:58:37 +0200
committerLeo Famulari <leo@famulari.name>2020-05-28 23:03:01 -0400
commitd7aef3ab59837b9ed8abbe199debf8ed687f6782 (patch)
tree13c2275f27c6d81a7634f3ecb28630546c595c3a /gnu/packages/file-systems.scm
parentd870fcfb099cf5b0ad25220e1fa36162cc3284a5 (diff)
downloadguix-d7aef3ab59837b9ed8abbe199debf8ed687f6782.tar
guix-d7aef3ab59837b9ed8abbe199debf8ed687f6782.tar.gz
gnu: Add exfatprogs.
* gnu/packages/file-systems.scm (exfatprogs): New public variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 03ad144fc2..1f58917d0c 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -187,6 +187,38 @@ caching system, and lets you assign different roles to each device based on its
performance and other characteristics.")
(license license:gpl2+))))
+(define-public exfatprogs
+ (package
+ (name "exfatprogs")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/exfatprogs/exfatprogs")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s47qvhr702z5c19wfqz8cwl9ammmincs7a8vjc6p974wnnjg77y"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-static")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/exfatprogs/exfatprogs")
+ (synopsis "Tools to create, check, and repair exFAT file systems")
+ (description
+ "These are command-line user space tools for the @acronym{exFAT,
+Extensible File Allocation Table} file systems. Included are
+@command{mkfs.exfat} to create (format) new exFAT file systems, and
+@command{fsck.exfat} to check their consistency and repair them.")
+ (license license:gpl2+)))
+
(define-public httpfs2
(package
(name "httpfs2")