aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-17 04:51:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-18 06:15:01 +0200
commit8dec0cdf6e552cd473b768e73c50cd3be3c042b4 (patch)
tree7d9cceb613fa0f4d3cb5dc0f15c59c546c0f1c4e /gnu/packages/engineering.scm
parent0ab5e91e1ced624c51cecc2693deb7c789fe1f07 (diff)
downloadguix-8dec0cdf6e552cd473b768e73c50cd3be3c042b4.tar
guix-8dec0cdf6e552cd473b768e73c50cd3be3c042b4.tar.gz
gnu: radare2: Update to 3.5.1.
* gnu/packages/engineering.scm (radare2): Update to 3.5.1.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ad70c0878f..7d48414889 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1248,17 +1248,17 @@ bindings for Python, Java, OCaml and more.")
(define-public radare2
(package
(name "radare2")
- (version "2.5.0")
+ (version "3.5.1")
(source (origin
(method url-fetch)
(uri (string-append "https://radare.mikelloc.com/get/" version "/"
"radare2-" version ".tar.gz"))
(sha256
(base32
- "17h4ba5qqahfi8mi4x2dcvq87cqpir5v2dlaqbvmay6vby4zh4v7"))
+ "174x5545fw2nyf000gd46hi7rx2bn3bw5bsnvizn9yi99pn7m4mw"))
(modules '((guix build utils)))
(snippet
- '(begin
+ '(begin
(substitute* "libr/asm/p/Makefile"
(("LDFLAGS\\+=") "LDFLAGS+=-Wl,-rpath=$(LIBDIR) "))
(substitute* "libr/parse/p/Makefile"
@@ -1268,7 +1268,7 @@ bindings for Python, Java, OCaml and more.")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f; tests require git and network access
+ '(#:tests? #f ; tests require git and network access
#:phases
(modify-phases %standard-phases
(add-before 'configure 'mklibdir