aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorguix-patches--- via <guix-patches@gnu.org>2024-08-18 11:22:59 +0900
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-19 13:36:55 +0800
commit724960a2642af6e3328b0e3de6b79344e895fb6b (patch)
tree589e2dbfe26c64d8c98c7e96f5084b49d752f0bc /gnu/packages/engineering.scm
parent734e83d4fafef11715eaada596e45c560d537f2e (diff)
downloadguix-724960a2642af6e3328b0e3de6b79344e895fb6b.tar
guix-724960a2642af6e3328b0e3de6b79344e895fb6b.tar.gz
gnu: Add zycore.
* gnu/packages/engineering.scm (zycore): New variable. Change-Id: Ia38413f43bc667a9a12916d3f0e786e06f6d358f Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 7a9c0bc436..e331e93e5a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
;;; Copyright © 2024 Juliana Sims <juli@incana.org>
+;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1927,6 +1928,32 @@ like relocation symbols. It is able to deal with malformed binaries, making
it suitable for security research and analysis.")
(license license:lgpl3)))
+(define-public zycore
+ (package
+ (name "zycore")
+ (version "1.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyantific/zycore-c")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s962pkqybh1xbs75y4jb4bqc9qnq0sviqd570mirqdhhq87agib"))))
+ (build-system cmake-build-system)
+ (native-inputs (list googletest))
+ (arguments (list #:configure-flags
+ #~(list "-DZYCORE_BUILD_SHARED_LIB=ON"
+ #$(if (%current-target-system)
+ "-DZYCORE_BUILD_TESTS=OFF"
+ "-DZYCORE_BUILD_TESTS=ON"))))
+ (home-page "https://github.com/zyantific/zycore-c")
+ (synopsis "Internal library for Zydis")
+ (description
+ "This package provides platfrom-independent types, macros
+and a fallback for environments without libc for Zydis.")
+ (license license:expat)))
+
(define-public asco
(package
(name "asco")