aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-14 23:20:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-15 20:21:03 +0100
commit49c2665f7b3a9c93634175774f6d9475255f57e9 (patch)
treeeb06140edc59eb5cdee7ddac0c94af11cdac56cb /gnu/packages/engineering.scm
parentb02b9a520ea1050fa51afde0e71cc7da32a5e0bb (diff)
downloadguix-49c2665f7b3a9c93634175774f6d9475255f57e9.tar
guix-49c2665f7b3a9c93634175774f6d9475255f57e9.tar.gz
gnu: Add pcb-rnd.
* gnu/packages/engineering.scm (pcb-rnd): New variable.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index b4d9af041a..f720906534 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -218,6 +218,33 @@ and design rule checking. It also includes an autorouter and a trace
optimizer; and it can produce photorealistic and design review images.")
(license license:gpl2+)))
+(define-public pcb-rnd
+ (package (inherit pcb)
+ (name "pcb-rnd")
+ (version "1.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://repo.hu/projects/pcb-rnd/releases/"
+ "pcb-rnd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pycynla60b96jkb6fh6f4sx663pqbzjwnixhw5ym8sym2absm09"))))
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'cc-is-gcc
+ (lambda _ (setenv "CC" "gcc") #t))
+ (replace 'configure
+ ;; The configure script doesn't tolerate most of our configure flags.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "sh" "configure"
+ (string-append "--prefix="
+ (assoc-ref outputs "out")))))))))
+ (home-page "http://repo.hu/projects/pcb-rnd/")
+ (description "PCB RND is a fork of the GNU PCB circuit board editing tool
+featuring various improvements and bug fixes.")))
+
(define-public fastcap
(package
(name "fastcap")