aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-11-09 11:32:25 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-11-09 11:55:08 +0100
commitddd925f608bf7bf9af367447ef937e92d531a941 (patch)
treeef1f325c867540fedef3b5ded1b95d47b19ca4df /gnu/packages/emacs.scm
parent2cce23bfb8fbb57c3f11780a939d74b5bd9ed3a2 (diff)
downloadguix-ddd925f608bf7bf9af367447ef937e92d531a941.tar
guix-ddd925f608bf7bf9af367447ef937e92d531a941.tar.gz
gnu: Add emacs-gtk-look.
* gnu/packages/emacs.scm (emacs-gtk-look): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3c7d902e11..c6008e6a94 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12500,3 +12500,41 @@ fix its formatting. @command{clang-format} is a tool that formats C/C++/Obj-C
code according to a set of style options, see
@url{http://clang.llvm.org/docs/ClangFormatStyleOptions.html}.")
(license license:gpl3+))))
+
+(define-public emacs-gtk-look
+ (package
+ (name "emacs-gtk-look")
+ (version "29")
+ (source (origin
+ (method url-fetch)
+ (uri "https://download.tuxfamily.org/user42/gtk-look.el")
+ (sha256
+ (base32
+ "14p2nwrd51cr1v06fxbjjn6jdrkf9d6vcxhmscm0kl677s25ypsp"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda _
+ ;; File is read-only.
+ (chmod "gtk-look.el" #o644)
+ (emacs-substitute-variables "gtk-look.el"
+ ("gtk-lookup-devhelp-indices"
+ '(list (expand-file-name "~/.guix-profile/share/gtk-doc/html/*/*.devhelp*"))))
+ #t)))))
+ (home-page "http://user42.tuxfamily.org/gtk-look/index.html")
+ (synopsis "Find and display HTML documentation for GTK, GNOME and Glib")
+ (description "@command{gtk-look} finds and displays HTML documentation for
+GTK, GNOME and Glib functions and variables in Emacs, similar to what
+info-lookup-symbol does for info files (C-h S). The documentation is expected
+to be devhelp indexes with HTML files. The location of the indexes can be
+customized. In addition to C code development @command{gtk-look} is good for
+
+@itemize
+@item @command{perl-gtk2}, recognising class funcs like
+@command{Gtk2::Label->new} and bare method names like @command{set_text}.
+@item @command{guile-gnome}, recognising methods like @command{set-text} and
+classes like @command{<gtk-window>}.
+@end itemize\n")
+ (license license:gpl3+)))