aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-01-06 17:49:45 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-01-06 17:50:08 +0100
commit41a3ace54e745fb78f3df354c09668e2a551d429 (patch)
tree22d5977d4117844f65a1cb41c4d45d5cbe79a060 /gnu/packages/emacs-xyz.scm
parent83460433b94487198750ad0bcc6f3869f68a8c8f (diff)
downloadguix-41a3ace54e745fb78f3df354c09668e2a551d429.tar
guix-41a3ace54e745fb78f3df354c09668e2a551d429.tar.gz
gnu: Add emacs-edn.
* gnu/packages/emacs-xyz.scm (emacs-edn): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2cab418bf5..eef7b1da55 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20863,3 +20863,27 @@ It also provides original Helm commands: @command{helm-cider-spec},
@command{helm-cider-spec-ns}, @command{helm-cider-repl-history},
@command{helm-cider-cheatsheet}.")
(license license:gpl3+))))
+
+(define-public emacs-edn
+ ;; No release since February 2016
+ (let ((commit "be9e32d1b49e35247b263b0243df7cfdc8d413ab"))
+ (package
+ (name "emacs-edn")
+ (version (git-version "1.1.2" "1" commit))
+ (home-page "https://github.com/expez/edn.el")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xp2hjhn52k6l1g6ypva6dsklpawni7gvjafbz6404f9dyxflh7l"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-peg" ,emacs-peg)))
+ (synopsis "Read and write EDN from Elisp")
+ (description "This is an Emacs Lisp library for reading and writing the
+data format @code{edn}. See @url{https://github.com/edn-format/edn}.")
+ (license license:gpl3+))))