aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-03-02 17:57:25 +0100
committerJohn Darrington <jmd@gnu.org>2017-03-02 18:02:26 +0100
commitf1021afb41613f5eba3ea4f5225b9a4cd1c15ecb (patch)
tree32139de4a2ae5f0e8a69af304719043e72b13f02 /gnu/packages/education.scm
parentec4102f57f724c3abafe9840f118160abfdbf292 (diff)
downloadguix-f1021afb41613f5eba3ea4f5225b9a4cd1c15ecb.tar
guix-f1021afb41613f5eba3ea4f5225b9a4cd1c15ecb.tar.gz
gnu: Merge the two stellaria into one.
* gnu/packages/astronomy.scm (stellaruim): Merge details from stellarium-0.14. * gnu/packages/education.scm (stellarium): Remove variable.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 5444579059..808be203c2 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -43,44 +43,6 @@
#:use-module (guix build-system cmake)
#:use-module (srfi srfi-1))
-(define-public stellarium
- (package
- (name "stellarium")
- (version "0.14.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/stellarium/"
- "Stellarium-sources/"
- version "/stellarium-" version ".tar.gz"))
- (sha256 (base32
- "1xxil0rv61zc08znfv83cpsc47y1gjl2f3njhz0pn5zd8jpaa15a"))))
- (build-system cmake-build-system)
- (inputs
- `(("qtbase" ,qtbase)
- ("zlib" ,zlib)
- ("qtserialport" ,qtserialport)
- ("qtscript" ,qtscript)
- ("gettext" ,gettext-minimal)))
- (native-inputs
- `(("qtbase" ,qtbase) ;Qt MOC is needed at compile time
- ("qttools" ,qttools)
- ("perl" ,perl))) ;for 'pod2man'
- (arguments
- `(#:test-target "tests"
- #:phases (modify-phases %standard-phases
- (add-before 'check 'set-offscreen-display
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp")
- #t)))))
- (home-page "http://www.stellarium.org/")
- (synopsis "3D sky viewer")
- (description "Stellarium is a planetarium. It shows a realistic sky in
-3D, just like what you see with the naked eye, binoculars, or a telescope. It
-can be used to control telescopes over a serial port for tracking celestial
-objects.")
- (license license:gpl2+)))
-
(define-public gcompris
(package
(name "gcompris")