aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2021-02-04 23:54:26 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-05 17:04:48 +0100
commitb7a225e3a3b40b6a60e5bbf940c8a65902ab61f8 (patch)
treebc198e10522ea53b4eddb72caeb91de0a9c77b79 /gnu/packages/documentation.scm
parente21eea0680c28491ec2dfa1119f7a8fa7ee64653 (diff)
downloadguix-b7a225e3a3b40b6a60e5bbf940c8a65902ab61f8.tar
guix-b7a225e3a3b40b6a60e5bbf940c8a65902ab61f8.tar.gz
gnu: zeal: Update to 0.6.1-1.d3c5521.
* gnu/packages/documentation.scm (zeal): Update to 0.6.1-1.d3c5521. [arguments]: Add phase wrap-qt-process-path. [inputs]: Add qtwebengine, qtwebchannel, qtdeclarative, qtquickcontrols. Remove qtwebkit. [home-page]: Changed to https://zealdocs.org/. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm76
1 files changed, 47 insertions, 29 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 0fca0b11eb..eb3227ca63 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -313,32 +313,50 @@ local system.")
(license lgpl2.1+)))
(define-public zeal
- (package
- (name "zeal")
- (version "0.6.1")
- (home-page "https://github.com/zealdocs/zeal")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "05qcjpibakv4ibhxgl5ajbkby3w7bkxsv3nfv2a0kppi1z0f8n8v"))))
- (build-system qt-build-system)
- (arguments `(#:tests? #f)) ; no tests
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("libarchive" ,libarchive)
- ("sqlite" ,sqlite)
- ("qtbase" ,qtbase)
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("xcb-util-keyms" ,xcb-util-keysyms)))
- (synopsis "Offline documentation browser inspired by Dash")
- (description "Zeal is a simple offline documentation browser
+ (let ((commit "d3c5521c501d24050f578348ff1b9d68244b992c")
+ (revision "1"))
+ (package
+ (name "zeal")
+ (version (git-version "0.6.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zealdocs/zeal")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ky2qi2cmjckc51lm3i28815ixgqdm36j7smixxr16jxpmbqs6sl"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'wrap 'wrap-qt-process-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/zeal"))
+ (qt-process-path (string-append
+ (assoc-ref inputs "qtwebengine")
+ "/lib/qt5/libexec/QtWebEngineProcess")))
+ (wrap-program bin
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
+ #t))))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libarchive" ,libarchive)
+ ("sqlite" ,sqlite)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebchannel" ,qtwebchannel)
+ ("qtwebengine" ,qtwebengine)
+ ("qtquickcontrols" ,qtquickcontrols)
+ ("qtx11extras" ,qtx11extras)
+ ("xcb-util-keyms" ,xcb-util-keysyms)))
+ (home-page "https://zealdocs.org/")
+ (synopsis "Offline documentation browser inspired by Dash")
+ (description "Zeal is a simple offline documentation browser
inspired by Dash.")
- (license gpl3+)))
+ (license gpl3+))))