aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 14:40:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 16:07:00 +0200
commit1b00e3bd2d79bb0f7752250f0f9f2c705dd09a75 (patch)
tree8e7d1c4c8f06dab69264cada6ba5f1d8714c8f35 /gnu/packages/dns.scm
parentee1362fc07a9977841d6f17b2e213c63901ed7ab (diff)
downloadguix-1b00e3bd2d79bb0f7752250f0f9f2c705dd09a75.tar
guix-1b00e3bd2d79bb0f7752250f0f9f2c705dd09a75.tar.gz
gnu: knot: Update to 2.7.1.
* gnu/packages/dns.scm (knot): Update to 2.7.1. [inputs]: Remove nettle, python-2, and python2-lmdb. [arguments]: Remove ‘wrap-python-scripts’ phase for removed migration scripts. Remove obsolete modules from, and add dnstap support for the command-line tools to, #:configure-flags.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm25
1 files changed, 7 insertions, 18 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index f8fd1877d6..7a80e1bd9b 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -498,14 +498,14 @@ Extensions} (DNSSEC).")
(define-public knot
(package
(name "knot")
- (version "2.6.7")
+ (version "2.7.1")
(source (origin
(method url-fetch)
(uri (string-append "https://secure.nic.cz/files/knot-dns/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0hr2m664ckjicv3pq2lk16m61pscknywxv2ydnrzfqf10m5h0ahw"))
+ "108k6x3hjsnyf06pv5rlxqhynjbbz13pzwax1mqff3hgv85f4skx"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -526,18 +526,14 @@ Extensions} (DNSSEC).")
("liburcu" ,liburcu)
("lmdb" ,lmdb)
("ncurses" ,ncurses)
- ("nettle" ,nettle)
- ("protobuf-c" ,protobuf-c)
-
- ;; For ‘pykeymgr’, needed to migrate keys from versions <= 2.4.
- ("python" ,python-2)
- ("python-lmdb" ,python2-lmdb)))
+ ("protobuf-c" ,protobuf-c)))
(arguments
`(#:phases
(modify-phases %standard-phases
(add-before 'configure 'disable-directory-pre-creation
(lambda _
;; Don't install empty directories like ‘/etc’ outside the store.
+ ;; This is needed even when using ‘make config_dir=... install’.
(substitute* "src/Makefile.in" (("\\$\\(INSTALL\\) -d") "true"))
#t))
(replace 'install
@@ -547,19 +543,12 @@ Extensions} (DNSSEC).")
(etc (string-append doc "/examples/etc")))
(invoke "make"
(string-append "config_dir=" etc)
- "install"))))
- (add-after 'install 'wrap-python-scripts
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (path (getenv "PYTHONPATH")))
- (wrap-program (string-append out "/sbin/pykeymgr")
- `("PYTHONPATH" ":" prefix (,path))))
- #t)))
+ "install")))))
#:configure-flags
(list "--sysconfdir=/etc"
"--localstatedir=/var"
- "--with-module-rosedb=yes" ; serve static records from a database
- "--with-module-dnstap=yes" ; allow detailed query logging
+ "--enable-dnstap" ; let tools read/write capture files
+ "--with-module-dnstap=yes" ; detailed query capturing & logging
(string-append "--with-bash-completions="
(assoc-ref %outputs "out")
"/etc/bash_completion.d"))))