aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 19:18:02 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:58:18 +0200
commitb0395dd68e0bfca3a1f672d29128b8dc520e203e (patch)
tree6037c6220ab8b30483edc0cc26cdba2e13b2a6f1 /gnu/packages/django.scm
parentcb9b6095dc656948fb7d0391d7c3936e38074b95 (diff)
downloadguix-b0395dd68e0bfca3a1f672d29128b8dc520e203e.tar
guix-b0395dd68e0bfca3a1f672d29128b8dc520e203e.tar.gz
gnu: Add python-django-sortedm2m.
* gnu/packages/django.scm (python-django-sortedm2m, python2-django-sortedm2m): New variables.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index de2d7db88b..bf78cd0784 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -545,3 +545,30 @@ settings.py and easily use them in your project.")
(define-public python2-django-rq
(package-with-python2 python-django-rq))
+
+(define-public python-django-sortedm2m
+ (package
+ (name "python-django-sortedm2m")
+ (version "1.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-sortedm2m" version))
+ (sha256
+ (base32
+ "0axf765i7b3c2s83nlph47asi8s071dhq8l7y382v1pw785s22vi"))))
+ (build-system python-build-system)
+ (arguments
+ ;; no tests.
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-django" ,python-django)))
+ (home-page "https://github.com/gregmuellegger/django-sortedm2m")
+ (synopsis "Drop-in replacement for django's own ManyToManyField")
+ (description
+ "Sortedm2m is a drop-in replacement for django's own ManyToManyField.
+The provided SortedManyToManyField behaves like the original one but remembers
+the order of added relations.")
+ (license license:bsd-3)))
+
+(define-public python2-django-sortedm2m
+ (package-with-python2 python-django-sortedm2m))