aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 18:58:30 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:51 +0200
commit49150e8a0063030973c9a41e2d48daca7ad96599 (patch)
tree4d28418f12db37c3f1d5da6314c02b1c8b42f00b /gnu/packages/django.scm
parenta13b522078a02b6df7f0494c0bd0ecec0e476e73 (diff)
downloadguix-49150e8a0063030973c9a41e2d48daca7ad96599.tar
guix-49150e8a0063030973c9a41e2d48daca7ad96599.tar.gz
gnu: Remove pootle.
This package depends on Python 2 which is past end-of-life and not supported by newer versions of some of the dependencies. * gnu/packages/django.scm (pootle): Remove variable.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm72
1 files changed, 0 insertions, 72 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 2370de62f5..dd066b5d67 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1006,78 +1006,6 @@ static files.")
(define-public python2-django-statici18n
(package-with-python2 python-django-statici18n))
-(define-public pootle
- (package
- (name "pootle")
- (version "2.8.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "Pootle" version ".tar.bz2"))
- (sha256
- (base32
- "1ng8igq0alsqzasgxdh3fb23581anyzp121h9041pwdzzv98kn4m"))))
- (build-system python-build-system)
- (arguments
- `(; pootle supports only python2.
- #:python ,python-2
- ;; tests are not run and fail with "pytest_pootle/data/po/.tmp: No such
- ;; file or directory". If we create this directory,
- ;; pytest_pootle/data/po/terminology.po is missing.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'fix-requirements
- (lambda _
- (substitute* "Pootle.egg-info/requires.txt"
- (("1.7.3") "1.8.0")
- (("2.0.0") "2.1.0"))
- (substitute* "requirements/tests.txt"
- (("==3.0.6") ">=3.0.6"))
- (substitute* "requirements/base.txt"
- (("1.7.3") "1.8.0")
- (("2.0.0") "2.1.0")))))))
- (propagated-inputs
- `(("django-allauth" ,python2-django-allauth)
- ("django-assets" ,python2-django-assets)
- ("django-bulk-update" ,python2-django-bulk-update)
- ("django-contact-form" ,python2-django-contact-form)
- ("django-contrib-comments" ,python2-django-contrib-comments)
- ("django-overextends" ,python2-django-overextends)
- ("django-redis" ,python2-django-redis)
- ("django-rq" ,python2-django-rq)
- ("django-sortedm2m" ,python2-django-sortedm2m)
- ("django-statici18n" ,python2-django-statici18n)
- ("babel" ,python2-babel)
- ("cssmin" ,python2-cssmin)
- ("diff-match-patch" ,python2-diff-match-patch)
- ("dirsync" ,python2-dirsync)
- ("elasticsearch" ,python2-elasticsearch)
- ("jsonfield" ,python2-django-jsonfield)
- ("lxml" ,python2-lxml)
- ("dateutil" ,python2-dateutil)
- ("levenshtein" ,python2-levenshtein)
- ("mysqlclient" ,python2-mysqlclient)
- ("psycopg2" ,python2-psycopg2)
- ("pytz" ,python2-pytz)
- ("rq" ,python2-rq)
- ("scandir" ,python2-scandir)
- ("stemming" ,python2-stemming)
- ("translate-toolkit" ,python2-translate-toolkit)))
- (native-inputs
- `(("python2-pytest" ,python2-pytest)
- ("python2-pytest-django" ,python2-pytest-django)
- ("python2-pytest-catchlog" ,python2-pytest-catchlog)
- ("python2-pytest-cov" ,python2-pytest-cov)
- ("python2-factory-boy" ,python2-factory-boy)))
- (home-page "https://pootle.translatehouse.org/")
- (synopsis "Community localization server")
- (description
- "Pootle is an online translation and localization tool. It works to
-lower the barrier of entry, providing tools to enable teams to work towards
-higher quality while welcoming newcomers.")
- (license license:gpl3+)))
-
(define-public python-django-tagging
(package
(name "python-django-tagging")