aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-05-07 20:45:39 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-05-09 20:08:30 +0200
commit49393691d75a3334d3abb8e54f4e08ce47734f03 (patch)
tree0f576a7a67c2812b8a12a6a4e9eb963d9159ec1e /gnu/packages/disk.scm
parent2f8b9c4648ef7b52e0bbae040914b007f565f877 (diff)
downloadguix-49393691d75a3334d3abb8e54f4e08ce47734f03.tar
guix-49393691d75a3334d3abb8e54f4e08ce47734f03.tar.gz
gnu: Add f3.
* gnu/packages/disk.scm (f3): New variable.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 93895278d6..a087141a87 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -337,3 +338,46 @@ project to detect and manipulate partition tables. Optional file system tools
permit managing file systems not included in libparted.")
;; The home page says GPLv2, but the source code says GPLv2+.
(license license:gpl2+)))
+
+
+(define-public f3
+ (package
+ (name "f3")
+ (version "6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/AltraMayor/f3/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mgbzc1swvgil45md1336j0aqkmkhwmpxical0ln5g09b2qxsanp"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ ;; Install without setting owner and group
+ (("\\$\\(INSTALL\\) -oroot -groot ") "$(INSTALL) ")
+ ;; also build and install experimental tools
+ (("^all: ") "all: $(EXPERIMENTAL_TARGETS) ")
+ (("^install: ") "install-all: ")
+ (("^install-experimental: ") "install: install-all "))
+ #t)))))
+ (inputs
+ `(("eudev" ,eudev)
+ ("parted" ,parted)))
+ (home-page "http://oss.digirati.com.br/f3/")
+ (synopsis "Test real capacity of flash memory cards and such.")
+ (description "F3 (Fight Flash Fraud or Fight Fake Flash) tests the full
+capacity of a flash card (flash drive, flash disk, pendrive). F3 writes to
+the card and then checks if can read it. It will assure you haven't been sold
+a card with a smaller capacity than stated.")
+ (license license:gpl3+)))