aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dictionaries.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-05-28 12:53:01 +0800
committer宋文武 <iyzsong@gmail.com>2016-05-28 12:53:01 +0800
commit68e9ee725a8f4744858ba171df6312f8d420af1a (patch)
treed49c5a7c3401feb2f5fef0d5e1c8711c63973182 /gnu/packages/dictionaries.scm
parentde477809d77393b8fb00d99cd35d65f77d157726 (diff)
downloadguix-68e9ee725a8f4744858ba171df6312f8d420af1a.tar
guix-68e9ee725a8f4744858ba171df6312f8d420af1a.tar.gz
gnu: Add gcide.
* gnu/packages/dictionaries.scm (gcide): New variable.
Diffstat (limited to 'gnu/packages/dictionaries.scm')
-rw-r--r--gnu/packages/dictionaries.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index ac020b27c8..5aea716150 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -76,3 +77,41 @@
"V.E.R.A. (Virtual Entity of Relevant Acronyms) is a list of computing
acronyms distributed as an info document.")
(license fdl1.3+)))
+
+(define-public gcide
+ (package
+ (name "gcide")
+ (version "0.51")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnu/gcide/gcide-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wm0s51ygc6480dq8gwahzr35ls8jgpf34yiwl5yqcaa0i19fdv7"))))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:builder (begin
+ (use-modules (guix build utils))
+ (let* ((src (assoc-ref %build-inputs "source"))
+ (tar (assoc-ref %build-inputs "tar"))
+ (xz (assoc-ref %build-inputs "xz"))
+ (out (assoc-ref %outputs "out"))
+ (datadir (string-append out "/share/gcide")))
+ (set-path-environment-variable "PATH" '("bin")
+ (list tar xz))
+ (mkdir-p datadir)
+ (zero? (system* "tar" "-C" datadir
+ "--strip-components=1"
+ "-xvf" src))))
+ #:modules ((guix build utils))))
+ (native-inputs
+ `(("tar" ,tar)
+ ("xz" ,xz)))
+ (synopsis "GNU Collaborative International Dictionary of English")
+ (description
+ "GCIDE is a free dictionary based on a combination of sources. It can
+be used via the GNU Dico program or accessed online at
+http://gcide.gnu.org.ua/")
+ (home-page "http://gcide.gnu.org.ua/")
+ (license gpl3+)))