aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dico.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
commit99f63f011df2aab38e98d7ee4608a8c70bf74c4d (patch)
tree3f224028f30c60f2ed7b9846365ad926192fc7e9 /gnu/packages/dico.scm
parente9a8b603337802a77ff2d68f0d30dc0e67721e3a (diff)
parent4f03aa23e805bd653de774e1d74ed2f50826899b (diff)
downloadguix-99f63f011df2aab38e98d7ee4608a8c70bf74c4d.tar
guix-99f63f011df2aab38e98d7ee4608a8c70bf74c4d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/dico.scm')
-rw-r--r--gnu/packages/dico.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/dico.scm b/gnu/packages/dico.scm
index b374a9b996..d96dbb86d9 100644
--- a/gnu/packages/dico.scm
+++ b/gnu/packages/dico.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,14 +38,14 @@
(define-public dico
(package
(name "dico")
- (version "2.5")
+ (version "2.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/dico/dico-"
version ".tar.xz"))
(sha256
(base32
- "0szm3z4xvq0pjj8kxl4paq63byamf281kzn1la0cdm5ngavypxxq"))))
+ "0dg4aacnmlf3ljssd7dwh8z5644xzq8k1501mbsx8nz8p8a9mbsq"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
@@ -57,12 +58,16 @@
;; infrastructure. Gag it.
(setenv "GUILE_AUTO_COMPILE" "0")
(setenv "GUILE_WARN_DEPRECATED" "no")
- #t)))))
+ #t))
+ (replace 'check
+ (lambda _
+ ;; Test '71: append + dooffs + env' fails if $V is not 2.
+ (invoke "make" "check" "V=2"))))))
(inputs
`(("m4" ,m4) ;used at run time
("pcre" ,pcre)
("python" ,python-2)
- ("guile" ,guile-2.0)
+ ("guile" ,guile-2.2)
("gsasl" ,gsasl)
("groff" ,groff)
("readline" ,readline)