aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/dhall.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-09 23:10:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-09 23:52:20 +0200
commit2971ed57345ee4e00058efeaf27c6a0790fdc9dd (patch)
tree7d0d6d06fcd9153120d03986a9b3ad784d2c53f2 /gnu/packages/dhall.scm
parent5e7daec9b4bfd2a3a430fc800ab6b1b527a5fa27 (diff)
downloadguix-2971ed57345ee4e00058efeaf27c6a0790fdc9dd.tar
guix-2971ed57345ee4e00058efeaf27c6a0790fdc9dd.tar.gz
gnu: dhall: Update to 1.32.0.
* gnu/packages/dhall.scm (dhall): Update to 1.32.0. [inputs]: Add ghc-half.
Diffstat (limited to 'gnu/packages/dhall.scm')
-rw-r--r--gnu/packages/dhall.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/dhall.scm b/gnu/packages/dhall.scm
index 86cbe764c6..c0776902e7 100644
--- a/gnu/packages/dhall.scm
+++ b/gnu/packages/dhall.scm
@@ -30,17 +30,14 @@
(define-public dhall
(package
(name "dhall")
- (version "1.31.1")
+ (version "1.32.0")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/dhall/dhall-"
- version
- ".tar.gz"))
+ (uri (string-append "https://hackage.haskell.org/package/dhall/dhall-"
+ version ".tar.gz"))
(sha256
- (base32
- "18v7vvcbcm9s7slh6h43rj9yakkkxwnwgj6kv84i6qzd2j7d80mc"))))
+ (base32 "1imj0bh5365pdizvjbw2wqz0g9hakigf1zm4fr6379qdchxpp90p"))))
(build-system haskell-build-system)
(inputs
`(("ghc-aeson" ,ghc-aeson)
@@ -56,6 +53,7 @@
("ghc-dotgen" ,ghc-dotgen)
("ghc-either" ,ghc-either)
("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-half" ,ghc-half)
("ghc-hashable" ,ghc-hashable)
("ghc-lens-family-core" ,ghc-lens-family-core)
("ghc-megaparsec" ,ghc-megaparsec)
@@ -131,10 +129,8 @@
"examples/True\" :: IO Bool"))
""))
#t)))))
- (home-page
- "https://dhall-lang.org/")
- (synopsis
- "Configuration language guaranteed to terminate")
+ (home-page "https://dhall-lang.org/")
+ (synopsis "Configuration language guaranteed to terminate")
(description
"Dhall is an explicitly typed configuration language that is not Turing
complete. Despite being Turing incomplete, Dhall is a real programming