aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-16 13:11:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-16 13:11:28 +0200
commit4cacd87e4d4b72945c19e993eef7af387fce957c (patch)
tree2f54fc1752941a849fa92c3f3a8bbb195e54b754 /gnu/packages/debug.scm
parent56f76b08be97549dcc409b090186103413dc4e4b (diff)
parent0f03c5316819385f3a4047ae50736b3db760f451 (diff)
downloadguix-4cacd87e4d4b72945c19e993eef7af387fce957c.tar
guix-4cacd87e4d4b72945c19e993eef7af387fce957c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 6278f661ef..27193c8bba 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -68,10 +68,10 @@
(mkdir-p bin)
(mkdir-p doc)
(for-each (lambda (h)
- (copy-file h (string-append doc "/" (basename h))))
+ (install-file h doc))
`("License.txt" ,@(find-files "www" ".*\\.html")))
(for-each (lambda (b)
- (copy-file b (string-append bin "/" b)))
+ (install-file b bin))
`("delta" "multidelta" "topformflat")))))
(alist-delete 'configure %standard-phases))))
(home-page "http://delta.tigris.org/")
@@ -212,13 +212,13 @@ tools that process C/C++ code.")
(system* "tar" "xf"
(assoc-ref inputs "afl-src")))
(error "tar failed to unpack afl-src"))
- (copy-file (string-append patch-dir
- "/afl-qemu-cpu-inl.h")
- "./afl-qemu-cpu-inl.h")
+ (install-file (string-append patch-dir
+ "/afl-qemu-cpu-inl.h")
+ ".")
(copy-file (string-append afl-dir "/config.h")
"./afl-config.h")
- (copy-file (string-append afl-dir "/types.h")
- "./types.h")
+ (install-file (string-append afl-dir "/types.h")
+ ".")
(substitute* "afl-qemu-cpu-inl.h"
(("\\.\\./\\.\\./config.h") "afl-config.h"))
(substitute* (string-append patch-dir