aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/debian.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-14 11:12:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-14 11:37:36 +0300
commit6226b8f72d87583322b075d4c51f253f9b13bc07 (patch)
tree5538cf5c167ddb978c79ff578fd1883936382e3e /gnu/packages/debian.scm
parent180502f28fbed79228549738fd550894dbdc2dc7 (diff)
downloadguix-6226b8f72d87583322b075d4c51f253f9b13bc07.tar
guix-6226b8f72d87583322b075d4c51f253f9b13bc07.tar.gz
gnu: debootstrap: Hardcode location of archive keyrings.
* gnu/packages/debian.scm (debootstrap)[arguments]: Adjust custom 'patch-source phase to hardcode the location of the archive keyrings.
Diffstat (limited to 'gnu/packages/debian.scm')
-rw-r--r--gnu/packages/debian.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 78cdd0d3f4..f011802ed3 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -226,6 +226,12 @@ contains the archive keys used for that.")
(substitute* "debootstrap"
(("=/usr") (string-append "=" #$output))
(("/usr/bin/dpkg") (search-input-file inputs "/bin/dpkg")))
+ ;; Include the keyring locations by default.
+ (substitute* (find-files "scripts")
+ (("keyring.*(debian-archive-keyring.gpg)"_ keyring)
+ (string-append "keyring " debian "/share/keyrings/" keyring))
+ (("keyring.*(ubuntu-archive-keyring.gpg)" _ keyring)
+ (string-append "keyring " ubuntu "/share/keyrings/" keyring)))
;; Ensure PATH works both in guix and within the debian chroot
;; workaround for: https://bugs.debian.org/929889
(substitute* "functions"