aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-02-26 21:55:52 -0500
committerMark H Weaver <mhw@netris.org>2016-02-29 20:09:29 -0500
commit8d5ceb120d34eab6ab557a82af9d4cd594dc35b7 (patch)
tree44e400b3374725b65db6156613dbdde6ad986e9c /gnu/packages/curl.scm
parentaa5946edb20a10a245ea24082bee0e01265235f9 (diff)
downloadguix-8d5ceb120d34eab6ab557a82af9d4cd594dc35b7.tar
guix-8d5ceb120d34eab6ab557a82af9d4cd594dc35b7.tar.gz
gnu: curl: Use updated libssh2 [fixes CVE-2016-7087].
* gnu/packages/curl.scm (curl)[inputs]: Use libssh2. * gnu/packages/ssh.scm (libssh2-1.4): Remove variable.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 46e0fa0f16..222910b655 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -54,16 +54,7 @@
(inputs `(("gnutls" ,gnutls)
("gss" ,gss)
("libidn" ,libidn)
-
- ;; XXX libssh2-1.4 is a temporary package for use only by curl,
- ;; to allow most users of libssh2 to get the security update for
- ;; CVE-2016-7087 while postponing the large number of rebuilds
- ;; entailed by updating curl. Soon, curl should be updated to
- ;; use the latest libssh2 and libssh2-1.4 should be removed.
-
- ;; XXX libssh2-1.4 is vulnerable to CVE-2016-0787.
- ("libssh2" ,libssh2-1.4)
-
+ ("libssh2" ,libssh2)
("openldap" ,openldap)
("zlib" ,zlib)))
(native-inputs