aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 21:36:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:33 +0300
commit8a1716fe3f69462eb0d436ff29bb8c17e799b0f5 (patch)
tree57173140e985012b8436249499ff9a1b458a60a0 /gnu/packages/curl.scm
parent4ac8d4864035d753429265a637b197356df8017b (diff)
downloadguix-8a1716fe3f69462eb0d436ff29bb8c17e799b0f5.tar
guix-8a1716fe3f69462eb0d436ff29bb8c17e799b0f5.tar.gz
gnu: curl: Update to 7.55.0.
* gnu/packages/curl.scm (curl): Update to 7.55.0. [replacement]: Remove field. [arguments]: Add phase to fix doc install location. (curl-7.55.0): Remove variable.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm43
1 files changed, 13 insertions, 30 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 23606b4810..2fb5245a45 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,15 +43,15 @@
(define-public curl
(package
(name "curl")
- (replacement curl-7.55.0)
- (version "7.54.1")
+ (version "7.55.0")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.haxx.se/download/curl-"
version ".tar.lzma"))
+ (patches (search-patches "curl-bounds-check.patch"))
(sha256
(base32
- "0vnv3cz0s1l5cjby86hm0x6pgzqijmdm97qa9q5px200956z6yib"))))
+ "1785vxi0jamiv9d1wr1l45g0fm9ircxdfyfzf7ld8zv0z0i8bmfd"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
@@ -109,7 +110,15 @@
;; The top-level "make check" does "make -C tests quiet-test", which
;; is too quiet. Use the "test" target instead, which is more
;; verbose.
- (zero? (system* "make" "-C" "tests" "test")))))))
+ (zero? (system* "make" "-C" "tests" "test"))))
+ (add-before 'install 'fix-Makefile
+ ;; Fix a regression in 7.55.0 where docs are not installed.
+ ;; https://github.com/curl/curl/commit/a7bbbb7c368c6096802007f61f19a02e9d75285b
+ (lambda _
+ (substitute* "Makefile"
+ (("install-data-hook:\n")
+ "install-data-hook:\n\tcd docs/libcurl && $(MAKE) install\n"))
+ #t)))))
(synopsis "Command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,
@@ -122,29 +131,3 @@ tunneling, and so on.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
(home-page "https://curl.haxx.se/")))
-
-(define-public curl-7.55.0
- (package
- (inherit curl)
- (version "7.55.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://curl.haxx.se/download/curl-"
- version ".tar.xz"))
- (patches (search-patches "curl-bounds-check.patch"))
- (sha256
- (base32
- "1785vxi0jamiv9d1wr1l45g0fm9ircxdfyfzf7ld8zv0z0i8bmfd"))))
- (arguments
- `(,@(substitute-keyword-arguments (package-arguments curl)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'install 'fix-Makefile
- ;; Fix a regression in 7.55.0 where docs are not installed.
- ;; https://github.com/curl/curl/commit/a7bbbb7c368c6096802007f61f19a02e9d75285b
- (lambda _
- (substitute* "Makefile"
- (("install-data-hook:\n")
- "install-data-hook:\n\tcd docs/libcurl && $(MAKE) install\n"))
- #t)))))))))