aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-05 21:23:00 -0400
committerLeo Famulari <leo@famulari.name>2016-08-10 15:29:41 -0400
commitddfba024d4401620192e7c314615f95fc5bb6d14 (patch)
treef192901696ebc7738b86946d3613fc49a7e5cec1 /gnu/packages/curl.scm
parent8d65c71f125798cf27c479b3e72ea61c9ba0d7b2 (diff)
downloadguix-ddfba024d4401620192e7c314615f95fc5bb6d14.tar
guix-ddfba024d4401620192e7c314615f95fc5bb6d14.tar.gz
gnu: curl: Update to 7.50.1.
* gnu/packages/curl.scm (curl)[replacement]: Remove field. [version, source]: Update to 7.50.1. [arguments]: Re-enable test. (curl-7.50.1): Remove variable.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm22
1 files changed, 2 insertions, 20 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index a250bb17d3..0e1badf869 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -40,15 +40,14 @@
(define-public curl
(package
(name "curl")
- (replacement curl-7.50.1)
- (version "7.47.0")
+ (version "7.50.1")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.haxx.se/download/curl-"
version ".tar.lzma"))
(sha256
(base32
- "1n284wdqzwb4bkmv0fnh36zl6lhlzy3clw2b7pn28kpgdy09ly7p"))))
+ "0qc3qp3h18v24irzw7dgg1jf39v4hnz8irv83v9lbn9rxzrpdcdj"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
@@ -84,10 +83,6 @@
(lambda _
(substitute* "tests/runtests.pl"
(("/bin/sh") (which "sh")))
- ;; Test #1135 requires extern-scan.pl, which is not part of the
- ;; tarball due to a mistake. It has been fixed upstream. We can
- ;; simply disable the test as it is specific to VMS and OS/400.
- (delete-file "tests/data/test1135")
;; XXX FIXME: Test #1510 seems to work on some machines and not
;; others, possibly based on the kernel version. It works on GuixSD
@@ -124,16 +119,3 @@ tunneling, and so on.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
(home-page "http://curl.haxx.se/")))
-
-(define curl-7.50.1
- (package
- (inherit curl)
- (source
- (let ((version "7.50.1"))
- (origin
- (method url-fetch)
- (uri (string-append "https://curl.haxx.se/download/curl-"
- version ".tar.lzma"))
- (sha256
- (base32
- "0qc3qp3h18v24irzw7dgg1jf39v4hnz8irv83v9lbn9rxzrpdcdj")))))))