aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-31 15:11:38 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-31 22:18:22 +0100
commitc300cae68233ec7cbf50c40bdea7c191eed21e54 (patch)
tree4046e334e300754aac0452ca1883e09c38cd9ae5 /gnu/packages/crypto.scm
parent55dee52b9c4dbb256ae9c5816efd13a019e55ed0 (diff)
downloadguix-c300cae68233ec7cbf50c40bdea7c191eed21e54.tar
guix-c300cae68233ec7cbf50c40bdea7c191eed21e54.tar.gz
gnu: crypto++: Don't use ‘-march=native’.
* gnu/packages/crypto.scm (crypto++)[arguments]: Add ‘disable-native-optimisation’ phase.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 92da952999..1ac704ddb8 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox>
-;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
@@ -595,6 +595,13 @@ data on your platform, so the seed itself will be as random as possible.
(list (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-native-optimisation
+ ;; This package installs more than just headers. Ensure that the
+ ;; cryptest.exe binary & static library aren't CPU model specific.
+ (lambda _
+ (substitute* "GNUmakefile"
+ ((" -march=native") ""))
+ #t))
(delete 'configure))))
(native-inputs
`(("unzip" ,unzip)))