aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-30 14:58:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-30 17:28:10 +0100
commitcdc129dc53b1c04e9a6577f7d2b9641a0a03c32f (patch)
tree7b2068768caa9755ef384be7dd29945cb35d80bd /gnu/packages/cran.scm
parent6e385b76e666bdf26fe4eebaffa93e48c123e5ef (diff)
downloadguix-cdc129dc53b1c04e9a6577f7d2b9641a0a03c32f.tar
guix-cdc129dc53b1c04e9a6577f7d2b9641a0a03c32f.tar.gz
gnu: Add r-psych.
* gnu/packages/cran.scm (r-psych): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4de3066834..a8de21ed76 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1208,6 +1208,40 @@ classification and bagging for classification, regression and survival
problems as well as resampling based estimators of prediction error.")
(license license:gpl2+)))
+(define-public r-psych
+ (package
+ (name "r-psych")
+ (version "1.7.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "psych" version))
+ (sha256
+ (base32
+ "0daismb8pdk392vdy304hqx0m3jx62gx3a0hygjygc125rhfla7k"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-foreign" ,r-foreign)
+ ("r-lattice" ,r-lattice)
+ ("r-mnormt" ,r-mnormt)
+ ("r-nlme" ,r-nlme)))
+ (home-page "http://cran.r-project.org/web/packages/psych/")
+ (synopsis "Procedures for psychological, psychometric, and personality research")
+ (description
+ "This package provides a general purpose toolbox for personality,
+psychometric theory and experimental psychology. Functions are primarily for
+multivariate analysis and scale construction using factor analysis, principal
+component analysis, cluster analysis and reliability analysis, although others
+provide basic descriptive statistics. Item Response Theory is done using
+factor analysis of tetrachoric and polychoric correlations. Functions for
+analyzing data at multiple levels include within and between group statistics,
+including correlations and factor analysis. Functions for simulating and
+testing particular item and test structures are included. Several functions
+serve as a useful front end for structural equation modeling. Graphical
+displays of path diagrams, factor analysis and structural equation models are
+created using basic graphics.")
+ (license license:gpl2+)))
+
(define-public r-recipes
(package
(name "r-recipes")