aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-30 14:58:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-30 17:28:10 +0100
commit6c8c8c6b759cd64382c7ede2aff8580bcbfb9f95 (patch)
tree417ad9340f657c7a4b3e30e7a72bf522f74df9a4 /gnu/packages/cran.scm
parentcdc129dc53b1c04e9a6577f7d2b9641a0a03c32f (diff)
downloadguix-6c8c8c6b759cd64382c7ede2aff8580bcbfb9f95.tar
guix-6c8c8c6b759cd64382c7ede2aff8580bcbfb9f95.tar.gz
gnu: Add r-broom.
* gnu/packages/cran.scm (r-broom): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a8de21ed76..0e1a45af46 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1242,6 +1242,39 @@ displays of path diagrams, factor analysis and structural equation models are
created using basic graphics.")
(license license:gpl2+)))
+(define-public r-broom
+ (package
+ (name "r-broom")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "broom" version))
+ (sha256
+ (base32
+ "119pc2jnxvm13cvd77c7d14p3bn68f4jm310vj3yfck40101n9if"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-nlme" ,r-nlme)
+ ("r-plyr" ,r-plyr)
+ ("r-psych" ,r-psych)
+ ("r-reshape2" ,r-reshape2)
+ ("r-stringr" ,r-stringr)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "http://github.com/tidyverse/broom")
+ (synopsis "Convert statistical analysis objects into tidy data frames")
+ (description
+ "This package provides tools to convert statistical analysis objects from
+R into tidy data frames, so that they can more easily be combined, reshaped
+and otherwise processed with tools like @code{dplyr}, @code{tidyr} and
+@code{ggplot2}. The package provides three S3 generics: @code{tidy}, which
+summarizes a model's statistical findings such as coefficients of a
+regression; @code{augment}, which adds columns to the original data such as
+predictions, residuals and cluster assignments; and @code{glance}, which
+provides a one-row summary of model-level statistics.")
+ (license license:expat)))
+
(define-public r-recipes
(package
(name "r-recipes")