aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-31 12:25:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-31 13:21:31 +0200
commitfe1495e35c0304f45f9114e388468dcf5f640c39 (patch)
treee1b7c89566a1daa9ca56369c44cb5d0783b31ac2 /gnu/packages/cran.scm
parent3ca317359ce0c99dfaecbf051867fcef19da7953 (diff)
downloadguix-fe1495e35c0304f45f9114e388468dcf5f640c39.tar
guix-fe1495e35c0304f45f9114e388468dcf5f640c39.tar.gz
gnu: Add r-jomo.
* gnu/packages/cran.scm (r-jomo): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 96044e114a..39114c7a16 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1841,6 +1841,32 @@ can be computed between character vectors while taking proper care of encoding
or between integer vectors representing generic sequences.")
(license license:gpl3+)))
+(define-public r-jomo
+ (package
+ (name "r-jomo")
+ (version "2.6-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "jomo" version))
+ (sha256
+ (base32
+ "0zyqwa2y08asj9xqwnngh6da1b9cqcx8pzc9cxwrmgnxd5nnsjb7"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lme4" ,r-lme4)
+ ("r-survival" ,r-survival)))
+ (home-page "https://cran.r-project.org/web/packages/jomo/")
+ (synopsis "Multilevel Joint Modelling Multiple Imputation")
+ (description
+ "Similarly to Schafer's package pan, jomo is a package for multilevel
+joint modelling multiple imputation @url{Carpenter and Kenward (2013),
+http://doi.org/10.1002/9781119942283}. Novel aspects of jomo are the
+possibility of handling binary and categorical data through latent normal
+variables, the option to use cluster-specific covariance matrices and to
+impute compatibly with the substantive model.")
+ (license license:gpl2)))
+
(define-public r-mice
(package
(name "r-mice")