aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-11-09 16:47:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-09 18:04:37 +0100
commitcf383cf08ff1b68a9610cddf66c1851b2aeddaab (patch)
treec15f1b91fb92d2df934bcce97ea38559c5831d0d /gnu/packages/cran.scm
parentda256afb9ed35bb15e7cab01a3aab76f1ec5639d (diff)
downloadguix-cf383cf08ff1b68a9610cddf66c1851b2aeddaab.tar
guix-cf383cf08ff1b68a9610cddf66c1851b2aeddaab.tar.gz
gnu: Add r-feature.
* gnu/packages/cran.scm (r-feature): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8c5c9258a9..ef3c148da1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7495,3 +7495,29 @@ distributions, modal clustering, discriminant analysis, and two-sample
hypothesis testing.")
;; Either version of the GPL.
(license (list license:gpl2 license:gpl3))))
+
+(define-public r-feature
+ (package
+ (name "r-feature")
+ (version "1.2.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "feature" version))
+ (sha256
+ (base32
+ "07hkw0bv38naj2hdsx4xxrm2dngi6w3rbvgr7s50bjic8hlgy1ra"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ks" ,r-ks)
+ ("r-misc3d" ,r-misc3d)
+ ("r-rgl" ,r-rgl)))
+ (home-page "http://www.mvstat.net/tduong/")
+ (synopsis "Inferential feature significance for kernel density estimation")
+ (description
+ "The feature package contains functions to display and compute kernel
+density estimates, significant gradient and significant curvature regions.
+Significant gradient and/or curvature regions often correspond to significant
+features (e.g. local modes).")
+ ;; Either version of the GPL.
+ (license (list license:gpl2 license:gpl3))))