aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-26 23:39:47 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-26 23:41:49 +0100
commitb0fd2bd3c5c1b04c3452473cdf104a8258bb7649 (patch)
tree5cbe086c3450dfd23041ead0fe1f877ac989301a /gnu/packages/commencement.scm
parent5335c56e8eb1953d7e14130896fea35309231134 (diff)
downloadguix-b0fd2bd3c5c1b04c3452473cdf104a8258bb7649.tar
guix-b0fd2bd3c5c1b04c3452473cdf104a8258bb7649.tar.gz
gnu: Add glibc-utf8-locales to the implicit inputs.
Suggested by Mark H Weaver and Andreas Enge at <http://lists.gnu.org/archive/html/guix-devel/2015-02/msg00356.html>. * gnu/packages/commencement.scm (gzip-final, glibc-utf8-locales-final): New variables. (%final-inputs): Use them.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 8fa90fed3f..aa0aac6d0e 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
@@ -662,6 +662,16 @@ store.")
("grep" ,grep-final)
,@%boot4-inputs))
+(define gzip-final
+ (package-with-explicit-inputs gzip %boot5-inputs
+ (current-source-location)))
+
+(define glibc-utf8-locales-final
+ (package
+ (inherit glibc-utf8-locales)
+ (inputs `(("glibc" ,glibc-final)
+ ("gzip" ,gzip-final)))))
+
(define-public %final-inputs
;; Final derivations used as implicit inputs by 'gnu-build-system'. We
;; still use 'package-with-bootstrap-guile' so that the bootstrap tools are
@@ -674,7 +684,6 @@ store.")
((name package)
(list name (finalize package))))
`(("tar" ,tar)
- ("gzip" ,gzip)
("bzip2" ,bzip2)
("xz" ,xz)
("file" ,file)
@@ -683,6 +692,7 @@ store.")
("sed" ,sed)
("findutils" ,findutils)
("gawk" ,gawk)))
+ ("gzip" ,gzip-final)
("grep" ,grep-final)
("coreutils" ,coreutils-final)
("make" ,gnu-make-final)
@@ -690,7 +700,8 @@ store.")
("ld-wrapper" ,ld-wrapper)
("binutils" ,binutils-final)
("gcc" ,gcc-final)
- ("libc" ,glibc-final))))
+ ("libc" ,glibc-final)
+ ("locales" ,glibc-utf8-locales-final))))
(define-public canonical-package
(let ((name->package (fold (lambda (input result)