aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-22 23:08:37 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-22 23:17:16 +0200
commit89223417fd82ff9f90a819e616da926485360f39 (patch)
treebeb3a0ca9fb293f25a583d25ca0acfc1524b6953 /gnu/packages/commencement.scm
parent790c3717d25eda6aba542227533e7edd83efa955 (diff)
downloadguix-89223417fd82ff9f90a819e616da926485360f39.tar
guix-89223417fd82ff9f90a819e616da926485360f39.tar.gz
gnu: commencement: Make a few variables private.
This removes ambiguity warnings when installing these packages. * gnu/packages/commencement.scm (glibc-final, gcc-final, glibc-utf8-locales-final): Make private.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index ebf770bfa7..d39f62d41c 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -470,7 +470,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(current-source-location)
#:guile %bootstrap-guile))))
-(define-public glibc-final
+(define glibc-final
;; The final glibc, which embeds the statically-linked Bash built above.
(package (inherit glibc-final-with-bootstrap-bash)
(name "glibc")
@@ -547,7 +547,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(propagated-inputs '())
(synopsis "GNU C++ standard library (intermediate)"))))
-(define-public gcc-final
+(define gcc-final
;; The final GCC.
(package (inherit gcc-boot0)
(name "gcc")
@@ -640,7 +640,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(current-source-location)
#:guile %bootstrap-guile)))
-(define-public glibc-utf8-locales-final
+(define glibc-utf8-locales-final
;; Now that we have GUILE-FINAL, build the UTF-8 locales. They are needed
;; by the build processes afterwards so their 'scm_to_locale_string' works
;; with the full range of Unicode codepoints (remember