aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-06 15:10:12 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-06 22:24:13 +0200
commit81cea47d4a4c0054beb234004b990d6f514d0514 (patch)
treea07974e003b1b7ed1667042bcfca96510f6b03dd /gnu/packages/commencement.scm
parent2a5739b4c0856721181e4e7ab4b747541a64efca (diff)
downloadguix-81cea47d4a4c0054beb234004b990d6f514d0514.tar
guix-81cea47d4a4c0054beb234004b990d6f514d0514.tar.gz
gnu: perl: Do not retain references to GCC & co.
Fixes <http://bugs.gnu.org/23077>. Reported by David Thompson <dthompson2@worcester.edu>. * gnu/packages/perl.scm (perl)[arguments]: Add 'remove-extra-references' phase. Remove -Dlibpth and -Dplibpth from #:configure-flags. * gnu/packages/commencement.scm (perl-boot0): Add #:disallowed-references.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm33
1 files changed, 18 insertions, 15 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 59a7c7798e..0d9133fb9c 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -270,21 +270,24 @@
(name "perl-boot0")
(replacement #f)
(arguments
- (substitute-keyword-arguments (package-arguments perl)
- ((#:phases phases)
- `(modify-phases ,phases
- ;; Pthread support is missing in the bootstrap compiler
- ;; (broken spec file), so disable it.
- (add-before 'configure 'disable-pthreads
- (lambda _
- (substitute* "Configure"
- (("^libswanted=(.*)pthread" _ before)
- (string-append "libswanted=" before))))))))))))
- (package-with-bootstrap-guile
- (package-with-explicit-inputs perl
- %boot0-inputs
- (current-source-location)
- #:guile %bootstrap-guile))))
+ ;; At the very least, this must not depend on GCC & co.
+ (let ((args `(#:disallowed-references
+ ,(list %bootstrap-binutils))))
+ (substitute-keyword-arguments (package-arguments perl)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ ;; Pthread support is missing in the bootstrap compiler
+ ;; (broken spec file), so disable it.
+ (add-before 'configure 'disable-pthreads
+ (lambda _
+ (substitute* "Configure"
+ (("^libswanted=(.*)pthread" _ before)
+ (string-append "libswanted=" before)))))))))))))
+ (package-with-bootstrap-guile
+ (package-with-explicit-inputs perl
+ %boot0-inputs
+ (current-source-location)
+ #:guile %bootstrap-guile))))
(define (linux-libre-headers-boot0)
"Return Linux-Libre header files for the bootstrap environment."