aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-26 13:03:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-29 23:31:35 +0200
commitb2fd8f63679aa4f244c36fdca62f23c00b8eded9 (patch)
tree399d35304a4a9d9624e06897ecee53ae9ec6e653 /gnu/packages/commencement.scm
parente18e17ea4ea9172402e782d69477bf15c1c25776 (diff)
downloadguix-b2fd8f63679aa4f244c36fdca62f23c00b8eded9.tar
guix-b2fd8f63679aa4f244c36fdca62f23c00b8eded9.tar.gz
gnu: glibc/linux: Fix runtime crashes on i686 systems.
* gnu/packages/patches/glibc-memchr-overflow-i686.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/commencement.scm (glibc-final-with-bootstrap-bash)[native-inputs]: Add the patch conditionally for i686 systems. * gnu/packages/base.scm (glibc/linux)[native-inputs]: Add the patch conditionally for i686 systems. [arguments]: Apply the patch conditionally on i686 systems.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 92f6e6c2ea..4fa34c93b1 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -22,6 +22,7 @@
(define-module (gnu packages commencement)
#:use-module ((guix licenses)
#:select (gpl3+ lgpl2.0+ public-domain))
+ #:use-module (gnu packages)
#:use-module (gnu packages bootstrap)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
@@ -509,7 +510,14 @@ the bootstrap environment."
(propagated-inputs `(("kernel-headers" ,(kernel-headers-boot0))))
(native-inputs
`(("texinfo" ,texinfo-boot0)
- ("perl" ,perl-boot0)))
+ ("perl" ,perl-boot0)
+ ;; Apply this patch only on i686 to avoid a full rebuild.
+ ;; TODO: Remove in the next update cycle.
+ ,@(if (string-prefix? "i686" (or (%current-target-system)
+ (%current-system)))
+ `(("glibc-memchr-overflow-i686.patch"
+ ,(search-patch "glibc-memchr-overflow-i686.patch")))
+ '())))
(inputs
`(;; The boot inputs. That includes the bootstrap libc. We don't want
;; it in $CPATH, hence the 'pre-configure' phase above.