aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-19 00:00:46 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-19 00:02:37 +0100
commit53088d0045a04b382a18a8fd171bc3e6560c6a06 (patch)
treeb918e1335857367e766db6753ff4714577e06993 /gnu/packages/commencement.scm
parent3eb34c631a143d77bf11bff2363a76959e45aa50 (diff)
downloadguix-53088d0045a04b382a18a8fd171bc3e6560c6a06.tar
guix-53088d0045a04b382a18a8fd171bc3e6560c6a06.tar.gz
gnu: commencement: Build Bison deterministically.
Before that entries in liby.a would contain the build time. * gnu/packages/commencement.scm (bison-boot1): Add #:make-flags.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 32facf2f47..d758913859 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -431,7 +431,14 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(bison (package (inherit bison)
(propagated-inputs `(("m4" ,m4)))
(inputs '()) ;remove Flex...
- (arguments '(#:tests? #f))))) ;... and thus disable tests
+ (arguments
+ '(#:tests? #f ;... and thus disable tests
+
+ ;; Zero timestamps in liby.a; this must be done
+ ;; explicitly here because the bootstrap Binutils don't
+ ;; do that (default is "cru".)
+ #:make-flags '("ARFLAGS=crD" "RANLIB=ranlib -D"
+ "V=1"))))))
(package
(inherit (package-with-bootstrap-guile
(package-with-explicit-inputs bison %boot0-inputs