aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-08-27 14:55:42 -0400
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:10:10 +0200
commit4176d47ef7561d1d3120538d71fe2f854cf7e452 (patch)
tree220f6f5bf4ac60c2a4437c2413638dfb470c9f84 /gnu/packages/chez.scm
parent92e8cff749aad27d32cb2242bf49ef508d8cef87 (diff)
downloadguix-4176d47ef7561d1d3120538d71fe2f854cf7e452.tar
guix-4176d47ef7561d1d3120538d71fe2f854cf7e452.tar.gz
gnu: stex: Fix read-only gifs and math directories.
Excplicitly set the user write bit when initializing the gifs or math directories from the skeletons installed in the store. See also upstream discussion at <https://github.com/dybvig/stex/pull/6>. This problem would be exposed by the upcoming changes to Racket's build system. * gnu/packages/patches/stex-copy-from-immutable-store.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/chez.scm (stex-bootstrap)[patches]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 043f2ae47a..812d41fc5b 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -613,6 +613,9 @@ Chez Scheme.")))
(sha256
(base32 "0n6dryv5j7cw2qmsj55wqb0ph901h83a2hl4j891ppxp0xx18nkp"))
(file-name (git-file-name name version))
+ (patches
+ ;; submitted upstream in https://github.com/dybvig/stex/pull/6
+ (search-patches "stex-copy-from-immutable-store.patch"))
(snippet
#~(for-each delete-file
'("sbin/install" "doc/stex.pdf" "doc/stex.html")))))