aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-10 15:37:13 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:09 +0000
commit8f36612d5b94616a7fbc3ae65b5cf331b2853e2c (patch)
tree6695dce459b2c226438b9295043a488b9e335a5a /gnu/packages/check.scm
parentcf5bd827cf74a313a8d56c38b125e25a60632b4f (diff)
downloadguix-8f36612d5b94616a7fbc3ae65b5cf331b2853e2c.tar
guix-8f36612d5b94616a7fbc3ae65b5cf331b2853e2c.tar.gz
gnu: Remove python-pytest-8.
* gnu/packages/check.scm (python-pytest-8): Set variable as deprecated. * gnu/packages/astronomy.scm (python-asdf) [native-inputs]: Remove python-pytest-8; add python-pytest. * gnu/packages/astronomy.scm (python-healpy) [native-inputs]: Remove python-pytest-8; add python-pytest. * gnu/packages/python-check.scm (python-pytest-cython) [propagated-inputs]: Remove python-pytest-8; add python-pytest. Change-Id: I89a6fbbc0152a6c2f0a9a22f8398a6bc4f9e86cb
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a5264a9e46..f1adfbb558 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1589,36 +1589,6 @@ and functions, detailed info on failing assert statements, modular fixtures,
and many external plugins.")
(license license:expat)))
-(define-public python-pytest-8
- (package/inherit python-pytest
- (name "python-pytest")
- (version "8.2.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest" version))
- (sha256
- (base32 "0xvr25qvmdh6z03jpgg24adhgqkvkal2g2v8vk63j6909q8bhjyy"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- #~(list "-k" (string-append
- "not test_code_highlight_continuation"
- " and not test_code_highlight"
- " and not test_code_highlight_custom_theme"
- " and not test_code_highlight_invalid_theme"
- " and not test_code_highlight_invalid_theme_mode"
- " and not test_code_highlight_simple"
- " and not test_color_yes"
- " and not test_comparisons_handle_colors"
- " and not test_empty_NO_COLOR_and_FORCE_COLOR_ignored"
- " and not test_remove_dir_prefix"))))
- (propagated-inputs
- (modify-inputs (package-propagated-inputs python-pytest)
- (append python-exceptiongroup)
- (replace "python-pluggy" python-pluggy-next)))))
-
(define-public python-pytest-next
(package/inherit python-pytest
(name "python-pytest")