aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 13:53:36 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:28 +0000
commit06cb215d9d2d2c81b4bfa3f0cf34d925ef2fa6e3 (patch)
tree291a0875eb0d90e1a2476c84dc3e8ec656bdaba8 /gnu/packages/check.scm
parent7427ff48be0db84a5dfb2283668f08cfdeb5cd4e (diff)
downloadguix-06cb215d9d2d2c81b4bfa3f0cf34d925ef2fa6e3.tar
guix-06cb215d9d2d2c81b4bfa3f0cf34d925ef2fa6e3.tar.gz
gnu: python-pytest-random-order: Update to 1.1.1.
* gnu/packages/check.scm (python-pytest-random-order): Update to 1.1.1. [build-system]: Swap to pyproject-build-system. [arguments]<test-flags>: Disable some failing tests. [native-inputs]: Add python-pytest-xdist, python-setuptools, python-py, and python-wheel. Change-Id: Iab4d940379f7995669f5ead9980bb8779c3266e4
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 42a1957de3..836432786b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1868,20 +1868,26 @@ decorators from external files.")
(define-public python-pytest-random-order
(package
(name "python-pytest-random-order")
- (version "1.0.4")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-random-order" version))
(sha256
- (base32 "0lpzl218l04vjy4gckrbrcacc3w9xrjnvz64bf2i132c58s5j8bb"))))
- (build-system python-build-system)
+ (base32 "104hww3b86jchk41kjhyycr541pd2dfgqkww6lx5y70z9z9xfwj4"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "--random-order")))))))
+ (list
+ #:test-flags
+ ;; AttributeError: module 'py' has no attribute 'code'.
+ #~(list "-k" (string-append "not test_it_works_with_actual_tests"
+ " and not test_failed_first"
+ " and not test_doctests"))))
+ (native-inputs
+ (list python-pytest-xdist
+ python-setuptools
+ python-py
+ python-wheel))
(propagated-inputs
(list python-pytest))
(home-page "https://github.com/jbasko/pytest-random-order")