aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-05-02 12:30:53 +0100
committerChristopher Baines <mail@cbaines.net>2020-05-02 12:30:53 +0100
commit29b0431d2f08c36113a56e16c3ef95cc19deb4f3 (patch)
tree27c4be472c31cc54b34f2b6a54baca042d555d95 /gnu/packages/check.scm
parent57833803b446484b6f413fb883b2156933c38639 (diff)
downloadguix-29b0431d2f08c36113a56e16c3ef95cc19deb4f3.tar
guix-29b0431d2f08c36113a56e16c3ef95cc19deb4f3.tar.gz
gnu: behave: Fix build with Python 3.8.core-updates-fix-behave
Add a patch based on an upstream commit [1]. 1: c000c88eb5239b87f299c85e83b349b0ef387ae7 * gnu/packages/patches/behave-skip-a-couple-of-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/check.scm (behave)[source]: Use the patch.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 05a796a3e3..2629e88323 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2107,7 +2107,9 @@ backported from Python 2.7 for Python 2.4+.")
(uri (pypi-uri "behave" version))
(sha256
(base32
- "11hsz365qglvpp1m1w16239c3kiw15lw7adha49lqaakm8kj6rmr"))))
+ "11hsz365qglvpp1m1w16239c3kiw15lw7adha49lqaakm8kj6rmr"))
+ (patches (search-patches
+ "behave-skip-a-couple-of-tests.patch"))))
(build-system python-build-system)
(native-inputs
`(("python-mock" ,python-mock)