aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 12:00:31 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 12:00:31 +0100
commit39afd2a8ce4ad1cac7ca02fbfee67540bc0b4c31 (patch)
treea441546bd1d01f04ec932403f4b8bad5b24221e5 /gnu/packages/check.scm
parentedc73cc2e5a310192a9360d632779c7b9ff7ebeb (diff)
downloadguix-39afd2a8ce4ad1cac7ca02fbfee67540bc0b4c31.tar
guix-39afd2a8ce4ad1cac7ca02fbfee67540bc0b4c31.tar.gz
gnu: python-lit: Fix tests.
* gnu/packages/check.scm (python-lit)[native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 71588109c8..05ed3eea32 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1213,6 +1213,14 @@ seamlessly into your existing Python unit testing work flow.")
(base32
"0z651m3vkbk85y41larnsjxrszkbi58x9gzml3lb6ga7qwcrsg97"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "py.test"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://llvm.org/")
(synopsis "LLVM Software Testing Tool")
(description "@code{lit} is a portable tool for executing LLVM and Clang