aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-14 18:23:36 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-14 18:55:52 +0200
commit19611b7a0aeb108512576efab63da4bdafd49890 (patch)
tree724ca50c664732477d3b07d60c60237bd11235c6 /gnu/packages/check.scm
parentd518261f05f81d49d64d2b1a44cde904bcc1cada (diff)
downloadguix-19611b7a0aeb108512576efab63da4bdafd49890.tar
guix-19611b7a0aeb108512576efab63da4bdafd49890.tar.gz
gnu: python-freezegun: Return #t from phase.
* gnu/packages/check.scm (python-freezegun)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b414cc147e..17fbcc68f9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1948,7 +1948,7 @@ create data based on random numbers and yet remain repeatable.")
;; package does not include the Makefile.
(replace 'check
(lambda _
- (zero? (system* "nosetests" "./tests/")))))))
+ (invoke "nosetests" "./tests/"))))))
(home-page "https://github.com/spulec/freezegun")
(synopsis "Test utility for mocking the datetime module")
(description