aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-06-12 22:02:04 -0400
committerLeo Famulari <leo@famulari.name>2016-06-12 22:09:26 -0400
commitee86e7e14859533045e1f7727ae731ba6ba72daf (patch)
treea5f51a9c4859a3242b46876797b98e77a5a7506e /gnu/packages/check.scm
parent8af5cac527eee03005f3809578a0d8258a878f95 (diff)
parentfe585be9aa8f5158a7dfb6477d19ece3d643dec3 (diff)
downloadguix-ee86e7e14859533045e1f7727ae731ba6ba72daf.tar
guix-ee86e7e14859533045e1f7727ae731ba6ba72daf.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 2b2dce9e9e..95c80438e9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
(define-module (gnu packages check)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages python)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
@@ -193,3 +195,62 @@ in the code. Cppcheck primarily detects the types of bugs that the compilers
normally do not detect. The goal is to detect only real errors in the code
(i.e. have zero false positives).")
(license gpl3+)))
+
+(define-public googletest
+ (package
+ (name "googletest")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/googletest/archive/"
+ "release-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1k0nf1l9cb3prdmsvaajl5i31bx86c1mw0d5jgzykz7rzm36afpp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("python-2" ,python-2)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'autoconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi"))))
+ (add-before 'autoconf 'generate-headers
+ (lambda _
+ (begin
+ (delete-file "include/gtest/gtest-param-test.h")
+ (system* "python2" "scripts/pump.py"
+ "include/gtest/gtest-param-test.h.pump")
+ (delete-file "include/gtest/internal/gtest-tuple.h")
+ (system* "python2" "scripts/pump.py"
+ "include/gtest//internal/gtest-tuple.h.pump")
+ (delete-file
+ "include/gtest/internal/gtest-param-util-generated.h")
+ (system*
+ "python2" "scripts/pump.py"
+ "include/gtest/internal/gtest-param-util-generated.h.pump")
+ (delete-file "include/gtest/internal/gtest-type-util.h")
+ (system* "python2" "scripts/pump.py"
+ "include/gtest/internal/gtest-type-util.h.pump"))))
+ (replace 'install
+ (lambda _
+ (let ((out (assoc-ref %outputs "out")))
+ (begin
+ (install-file "lib/.libs/libgtest_main.a"
+ (string-append out "/lib"))
+ (install-file "lib/.libs/libgtest.a"
+ (string-append out "/lib"))
+ (copy-recursively "include"
+ (string-append out "/include")))))))))
+ (home-page "https://github.com/google/googletest/")
+ (synopsis "Test discovery and XUnit test framework")
+ (description "Google Test features an XUnit test framework, automated test
+discovery, death tests, assertions, parameterized tests and XML test report
+generation.")
+ (license bsd-3)))