aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-04-20 17:58:24 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-05-10 09:32:48 +0200
commit76e98457347207459417f46c2f542b6a9f03fb7f (patch)
tree1cb0f131cbfcb81e76fa735408e5b521aa20a403 /gnu/packages/cdrom.scm
parentded5966585cc75da53ad7bfb266f9b861aa71ed3 (diff)
downloadguix-76e98457347207459417f46c2f542b6a9f03fb7f.tar
guix-76e98457347207459417f46c2f542b6a9f03fb7f.tar.gz
gnu: Add dvd+rw-tools.
* gnu/packages/cdrom.scm (dvd+rw-tools): New variable. * gnu/packages/patches/dvd+rw-tools-add-include.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index c0ba337da1..759375e45d 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 John Darrington <jmd@gnu.org>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,6 +42,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages glib)
#:use-module (gnu packages man)
+ #:use-module (gnu packages m4)
#:use-module (gnu packages mp3)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages elf)
@@ -254,6 +256,47 @@ images.")
;; mkisofs is GPL, the other programs are CDDL.
(license (list cddl1.0 gpl2))))
+(define-public dvd+rw-tools
+ (package
+ (name "dvd+rw-tools")
+ (version "7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://fy.chalmers.se/~appro/linux/DVD+RW/tools/dvd+rw-tools-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1jkjvvnjcyxpql97xjjx0kwvy70kxpiznr2zpjy2hhci5s10zmpq"))
+ (patches (search-patches "dvd+rw-tools-add-include.patch"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("cdrtools" ,cdrtools)))
+ (native-inputs
+ `(("m4" ,m4)))
+ (arguments
+ `(#:tests? #f ; No tests.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _ (setenv "prefix" (assoc-ref %outputs "out")) #t))
+ (add-before 'build 'embed-mkisofs
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; We use sed --in-place because substitute* cannot handle the
+ ;; character encoding used by growisofs.c.
+ (zero? (system* "sed" "-i" "-e"
+ (string-append
+ "s,\"mkisofs\","
+ "\"" (which "mkisofs") "\",")
+ "growisofs.c")))))))
+ (home-page "http://fy.chalmers.se/~appro/linux/DVD+RW/")
+ (synopsis "DVD and Blu-ray Disc burning tools")
+ (description "dvd+rw-tools, mostly known for its command
+@command{growisofs}, is a collection of DVD and Blu-ray Disc burning tools.
+It requires another program, such as @command{mkisofs}, @command{genisoimage},
+or @command{xorrisofs} to create ISO 9660 images.")
+ (license gpl2)))
+
(define-public dvdisaster
(package
(name "dvdisaster")