aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-04-26 17:46:57 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-05-04 22:15:50 -0400
commite5326da4f4111e991fa695d7d7b566d384f82895 (patch)
tree5291191d1ddcb18ced5a43433348879fe9cc0748 /gnu/packages/calendar.scm
parent2b226af1bc663fee6ebe14305add2974b9daedbc (diff)
downloadguix-e5326da4f4111e991fa695d7d7b566d384f82895.tar
guix-e5326da4f4111e991fa695d7d7b566d384f82895.tar.gz
gnu: Add libical.
* gnu/packages/calendar.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
new file mode 100644
index 0000000000..7e87fbbfe4
--- /dev/null
+++ b/gnu/packages/calendar.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages calendar)
+ #:use-module (gnu packages)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages perl))
+
+(define-public libical
+ (package
+ (name "libical")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/libical/libical/releases/download/v"
+ version "/libical-" version ".tar.gz"))
+ (sha256
+ (base32
+ "14lmjj63zyx88rf1z71l0v9ms4c2vpdhmixksjjxgywp5p2f7708"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; test suite appears broken
+ (native-inputs
+ `(("perl" ,perl)))
+ (inputs
+ `(("icu4c" ,icu4c)))
+ (home-page "https://libical.github.io/libical/")
+ (synopsis "iCalendar protocols and data formats implementation")
+ (description
+ "Libical is an implementation of the iCalendar protocols and protocol
+data units.")
+ (license lgpl2.1)))