aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-12 22:28:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-13 23:17:00 +0200
commit33f79a74b8f97fc39587ca66d38f0d82548bfe28 (patch)
tree88efc39c6940bb237951cbe20fed52ceaca528c6 /gnu/packages/build-tools.scm
parent4264db22095882b7706ae2b9680bde2d355987b3 (diff)
downloadguix-33f79a74b8f97fc39587ca66d38f0d82548bfe28.tar
guix-33f79a74b8f97fc39587ca66d38f0d82548bfe28.tar.gz
gnu: Add bam.
* gnu/packages/build-tools.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
new file mode 100644
index 0000000000..8901a46576
--- /dev/null
+++ b/gnu/packages/build-tools.scm
@@ -0,0 +1,64 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages build-tools)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages python)
+ #:use-module (guix build-system gnu))
+
+(define-public bam
+ (package
+ (name "bam")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://github.com/downloads/matricks/"
+ "bam/bam-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0z90wvyd4nfl7mybdrv9dsd4caaikc6fxw801b72gqi1m9q0c0sn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (zero? (system* "bash" "make_unix.sh"))))
+ (replace 'check
+ (lambda _
+ (zero? (system* "python" "scripts/test.py"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p bin)
+ (install-file "bam" bin)
+ #t))))))
+ (native-inputs
+ `(("python" ,python-2)))
+ (home-page "https://matricks.github.io/bam/")
+ (synopsis "Fast and flexible build system")
+ (description "Bam is a fast and flexible build system. Bam uses Lua to
+describe the build process. It takes its inspiration for the script files
+from scons. While scons focuses on being 100% correct when building, bam
+makes a few sacrifices to acquire fast full and incremental build times.")
+ (license license:bsd-3)))